Rebuilding a 1.4.0 Project from 2017

Support forum for users of the M1 Build

Rebuilding a 1.4.0 Project from 2017

Postby PEI330Ci on Sat May 18, 2024 12:13 am

Hello,

From 2014 to 2017 I developed my own M1 Build project for private use. I started with version 1.3, and upgraded to 1.4.0 when it came out. To give an idea of the amount of progress made, the original Project had under 11,000 objects, and the last version I was running in December 2017 had over 17,000 objects. There is a fair amount of work into this.

Having changed multiple computers, adding the latest version of M1 build to each, I now find that I cannot compile the original project from 2017.

I've since backtracked, installing Build Version 1.4.0.0131 from March 2016, but I get a new set of errors. I've tried a number of the usual tricks, such as manually adjusting Module versions, but I've so far only achieved increases in the number of errors.

Does anyone recognize the below issue, and have a tip to solve it?

Unknown Object Class Error.JPG
Unknown Object Class Error.JPG (478.68 KiB) Viewed 357 times
PEI330Ci
 
Posts: 56
Joined: Wed Feb 27, 2013 3:58 am

Re: Rebuilding a 1.4.0 Project from 2017

Postby Stephen Dean on Mon May 20, 2024 10:57 am

There is a symbiosis between the Build Version, the System version, Project base and the Modules in use with in a M1 Build Project. If one of these doesn't line up, or is not compatible with another item, then you will get these errors. What is showing at the moment appears to be that you have a mismatch with the MoTeC Input Module, and one or more of the other Modules and/or the System file that you have chosen.

Unfortunately, there is not a matrix of compatibility for the System and Module files to ease the troubleshooting needed for this, it is a matter of changing one module and rebuilding to see if the issue remains.

I would also do a compare with the last known good Project and see what has changed.
Stephen Dean
MoTeC Research Centre Melbourne, Australia
User avatar
Stephen Dean
Site Admin
 
Posts: 1632
Joined: Tue Dec 02, 2014 10:29 am
Location: Melbourne

Re: Rebuilding a 1.4.0 Project from 2017

Postby PEI330Ci on Mon May 20, 2024 7:06 pm

Stephen,

Thanks for the feedback, this correlates with my previous experiences post version updates.

I'll have to do some digging into old hard drives to check save dates of projects, and hope for a winner.

Otherwise, we're off to the module version races....
PEI330Ci
 
Posts: 56
Joined: Wed Feb 27, 2013 3:58 am


Return to M1 Build

Who is online

Users browsing this forum: No registered users and 2 guests